simulacion y distribuicion lentas  

  RSS

joalex1234
(@joalex1234)
Eminent Member
Registrado: hace 2 años
Respuestas: 23
19/03/2019 3:26 pm  

hola buenas que posibilidades se tiene en mejorar el rendimiento al simular proyectos o a la hora de ejecutar una distribución, nunca había presentado tal problema asta que tuve que crear un proyecto algo mayor con 3 ventanas, mi equipo es un core i7 8gb de ram y disco de estado solido solo tengo bastante lag al ejecutar tales proyectos, mi versión es la 3.12


Citar
admin
(@admin)
Miembro Admin
Registrado: hace 2 años
Respuestas: 104
21/03/2019 3:38 pm  

Buen día,

Podría por favor enviarme el código que realizó al correo para verificar cual de los elementos causa la lentitud?

Por el momento creo que dicha lentitud se está presentando por los elementos de comunicación serial pero necesito más casos para verificar si es por el estilo de programación y tratar de corregir el funcionamiento de los elementos.

 

Cordial saludo,

Javier Velásquez


ResponderCitar
joalex1234
(@joalex1234)
Eminent Member
Registrado: hace 2 años
Respuestas: 23
26/03/2019 4:55 pm  

Hola e revisado y encontré que al agrandar los elementos en el panel frontal como los numéricos o gráficos me provoca dicho lag el cual es bastante y si los dejo los elementos pequeños este ya se siente un poco mas fluido, te mande el programa por correo, gracias   


ResponderCitar
CmKranevitter
(@cmkranevitter)
New Member
Registrado: hace 5 meses
Respuestas: 1
24/05/2019 8:01 am  

Buenos días, soy nuevo en el foro. Estoy experimentando con myopenlab hace un tiempo.

Estoy haciendo un proyecto con Raspberry y Arduino con el protocolo Firmata y tengo un problema similar.

La aplicación se vuelve lenta cuando pasa tiempo sin utilizarla (en espera) hasta el punto de clavarse por completo.

Podría enviarle el proyecto para que lo vea?

Desde ya muchas gracias.


ResponderCitar
admin
(@admin)
Miembro Admin
Registrado: hace 2 años
Respuestas: 104
24/05/2019 9:25 pm  

Hola, si señor lo puede enviar admin@myopenlab.org


ResponderCitar
admin
(@admin)
Miembro Admin
Registrado: hace 2 años
Respuestas: 104
20/09/2019 11:55 pm  

Buen día,

Para este tema de la lentitud de MyOpenLab v3.12.0 (versión en desarrollo) cuando se usa puerto serie con el elemento firmata se consumen muchos recursos de RAM y se va poniendo cada vez más lento.

Ya se realizó el ajuste y lo pueden descargar y probar:

https://myopenlab.org/Downloads/DeveloperPreview/distribution_win64_3.12.1.zip

https://myopenlab.org/Downloads/DeveloperPreview/distribution_win32_3.12.1.zip

https://myopenlab.org/Downloads/DeveloperPreview/distribution_macosx_3.12.1.zip

https://myopenlab.org/Downloads/DeveloperPreview/distribution_armhf_3.12.1.zip

 

Saludos,

Javier Velásquez


ResponderCitar
Share: